What mobile devices do you support?

iPhone, iPad, iPod touch
Use the Cubby iOS app on any iPhone, iPad, or iPod touch running iOS version 5.0 or above.

Android
Use the Cubby Android app on any device running Android 2.3.3 or above.

Windows Phone and BlackBerry
There is no Cubby app for Windows Phone or BlackBerry.

Feedback and Knowledge Base