System requirements

Windows
Use the Cubby desktop application and cubby.com on any PC running Windows 8, 7, Vista, XP (SP3), Server 2003 (with IE7+), 2008, 2012 (all including 64-bit).
Note: Cubby does not run as a service

Cubby is not yet officially supported on Windows 10
Known issue: Pinned folders may not open while Cubby is running in Windows 10.

Mac
Use the Cubby desktop application and cubby.com on any Intel-based Mac running 10.9 (Mavericks), 10.8 (Mountain Lion), 10.7 (Lion), 10.6.6 (Snow Leopard).

Linux
Linux is not supported, but folks on Linux can access their cloud-enabled cubbies via the Cubby WebDAV server. Show me how

Browsers on a PC or Mac
Use cubby.com with up-to-date versions of the following browsers: Chrome, Safari, Firefox, Internet Explorer (IE) 8+

iOS (iPhone, iPad, iPod touch)
Use the Cubby iOS app on any iPhone, iPad, or iPod touch running iOS version 5.0 or above.

Android
Use the Cubby Android app on any device running Android 2.3.3 or above.

Windows Phone and BlackBerry
There is no Cubby app for Windows Phone or BlackBerry.


Important: Cubby is designed for use with third-party products and services (browser, OS, etc.) that are officially supported by their respective vendors and well-maintained by the end user (latest patches and updates installed). Learn more

Feedback and Knowledge Base